Thread (11 messages) 11 messages, 3 authors, 2023-08-24

Re: [PATCH v5 1/4] clk: qcom: branch: Add clk_branch2_mdio_ops

From: Stephen Boyd <sboyd@kernel.org>
Date: 2023-08-23 18:04:41
Also in: linux-arm-msm, linux-clk, lkml

Quoting Luo Jie (2023-08-23 01:50:28)
quoted hunk ↗ jump to hunk
diff --git a/drivers/clk/qcom/clk-branch.c b/drivers/clk/qcom/clk-branch.c
index fc4735f74f0f..5e08c026ca4a 100644
--- a/drivers/clk/qcom/clk-branch.c
+++ b/drivers/clk/qcom/clk-branch.c
@@ -153,3 +153,10 @@ const struct clk_ops clk_branch_simple_ops = {
        .is_enabled = clk_is_enabled_regmap,
 };
 EXPORT_SYMBOL_GPL(clk_branch_simple_ops);
+
+const struct clk_ops clk_branch2_mdio_ops = {
+       .prepare = clk_branch2_enable,
+       .unprepare = clk_branch2_disable,
+       .is_prepared = clk_is_enabled_regmap,
+};
+EXPORT_SYMBOL_GPL(clk_branch2_mdio_ops);
I'd call it clk_branch2_simple_prepare_ops or something like that.
There's nothing mdio specific about it.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help