Thread (10 messages) 10 messages, 3 authors, 2022-11-07

Re: [PATCH 2/2] dt-bindings: phy: Fix UniPhier SATA controller node names in example

From: Kunihiko Hayashi <hayashi.kunihiko@socionext.com>
Date: 2022-11-07 02:36:50
Also in: linux-arm-kernel, linux-phy, lkml

Hi Vinod,

On 2022/11/05 16:34, Vinod Koul wrote:
On 02-11-22, 08:14, Kunihiko Hayashi wrote:
quoted
On 2022/11/02 4:31, Rob Herring wrote:
quoted
On Tue, Nov 1, 2022 at 4:10 AM Kunihiko Hayashi
[off-list ref] wrote:
quoted
Hi Rob,

On 2022/10/29 4:38, Rob Herring wrote:
quoted
On Thu, Oct 27, 2022 at 01:49:20PM +0900, Kunihiko Hayashi wrote:
quoted
The word "glue" is ambiguous for the controller node name.
Should put
quoted
quoted
quoted
quoted
quoted
"sata-controller" instead of "ahci-glue" on the controller node.
And rename a phy node to "sata-phy".

Signed-off-by: Kunihiko Hayashi <hayashi.kunihiko@socionext.com>
---
    .../devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml
| 4
quoted
quoted
quoted
quoted
quoted
++--
    1 file changed, 2 insertions(+), 2 deletions(-)

diff --git
a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml
quoted
quoted
quoted
quoted
b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml
quoted
quoted
quoted
quoted
quoted
index a3cd45acea28..89b8b133777a 100644
---
a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.
quoted
quoted
quoted
quoted
yaml
quoted
+++
b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.
quoted
quoted
quoted
quoted
yaml
quoted
@@ -117,14 +117,14 @@ additionalProperties: false

    examples:
      - |
-    ahci-glue@65700000 {
+    sata-controller@65700000 {
But is this really the SATA controller aka AHCI?

In cases where we don't have a standardized name, I don't think it
makes
quoted
quoted
quoted
quoted
sense changing node names from one non-standard name to another.
I see. This can't be named generic, so this change will drop.
And "sata-phy" in the same way.
I think sata-phy is fine. It may not be added, but usb3-phy or
pcie-phy are common already.
I understand. But of cource "phy" is also common, so I defer the change
from "phy" to "sata-phy".
Should it not be just phy@xxx does it really need to be foo-phy?
This change was pointed out in the previous review for our devicetree,
so I made this change in the devicetree, however, I think I can leave it
as "phy" until the properties that depend on "sata-phy" are defined.

Thank you,

---
Best Regards
Kunihiko Hayashi
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help