On Wed, Oct 19, 2022 at 04:44:33PM +0300, Dmitry Baryshkov wrote:
On 19/10/2022 16:25, Johan Hovold wrote:
quoted
On Wed, Oct 19, 2022 at 04:12:02PM +0300, Dmitry Baryshkov wrote:
quoted
On 19/10/2022 14:35, Johan Hovold wrote:
quoted
Generalise the serdes initialisation helper so that it can be used to
initialise all the PHY registers (e.g. serdes, tx, rx, pcs).
Note that this defers the ungating of the PIPE clock somewhat, which is
fine as it isn't needed until starting the PHY.
Signed-off-by: Johan Hovold <johan+linaro@kernel.org>
---
drivers/phy/qualcomm/phy-qcom-qmp-pcie.c | 51 +++++++-----------------
1 file changed, 15 insertions(+), 36 deletions(-)
quoted
quoted
quoted
-static void qmp_pcie_pcs_init(struct qmp_pcie *qmp, const struct qmp_phy_cfg_tables *tables)
-{
- void __iomem *pcs = qmp->pcs;
- void __iomem *pcs_misc = qmp->pcs_misc;
-
- if (!tables)
- return;
- qmp_pcie_configure(pcs, tables->pcs, tables->pcs_num);
- qmp_pcie_configure(pcs_misc, tables->pcs_misc, tables->pcs_misc_num);
+ qmp_pcie_configure(pcs, tbls->pcs, tbls->pcs_num);
+ qmp_pcie_configure(pcs_misc, tbls->pcs_misc, tbls->pcs_misc_num);
Nit: could we please keep it as `tables'?
I considered that but found that the longer identifier hurt
readability so I prefer to use "tbls" here.
I'd say, it's up to Vinod. I'd prefer the second version.
Ultimately yes, but as the author of these patches I do have a say here.
Johan