On Tue, Jul 12, 2022 at 6:36 PM Francesco Dolcini
[off-list ref] wrote:
Use sub-function of_compatible during probe, instead of using the node
name. The code should not rely on the node names during probe, in
addition to that the previously hard-coded node names are not compliant
to the latest naming convention (they are not generic and they use
underscores), and it was broken by mistake already once [1].
[1] commit 56086b5e804f ("ARM: dts: imx6qdl-apalis: Avoid underscore in node name")
Suggested-by: Ahmad Fatoum <a.fatoum@pengutronix.de>
Signed-off-by: Francesco Dolcini <redacted>
---
v2:
- remove define usage for compatible strings
- moved rotator removal from probe to a separate patch
v2 LGTM
Reviewed-by: Linus Walleij <redacted>
Yours,
Linus Walleij