Thread (8 messages) flat view 8 messages, 4 authors, 2022-03-05

Re: [PATCH 3/4 v5] dts: rockchip: Update regulator name for PX3

From: Robin Murphy <robin.murphy@arm.com>
Date: 2022-03-04 13:47:36
Also in: linux-rockchip

On 2022-03-03 20:39, Chris Morgan wrote:
From: Chris Morgan <redacted>

The regulator name of SWITCH_REG1 does not match any other board
with a rk818 PMIC, nor does it correspond to a regulator in the
rk808-regulator driver. Changing name to SWITCH_REG which is
consistent with other boards and is in the driver.
The datasheet I found also names the channel "SWITCH" rather than 
"SWITCH1", so this seems correct to me.

Reviewed-by: Robin Murphy <robin.murphy@arm.com>
quoted hunk ↗ jump to hunk
Signed-off-by: Chris Morgan <redacted>
---
  arch/arm/boot/dts/rk3188-px3-evb.dts | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/rk3188-px3-evb.dts b/arch/arm/boot/dts/rk3188-px3-evb.dts
index 39c60426c9c9..fc478ac4e781 100644
--- a/arch/arm/boot/dts/rk3188-px3-evb.dts
+++ b/arch/arm/boot/dts/rk3188-px3-evb.dts
@@ -212,7 +212,7 @@ wl_18: LDO_REG8 {
  				regulator-name = "wl_18";
  			};
  
-			lcd_33: SWITCH_REG1 {
+			lcd_33: SWITCH_REG {
  				regulator-name = "lcd_33";
  			};
  		};
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help