On Thu, Nov 25, 2021 at 09:26:15AM -0600, Samuel Holland wrote:
quoted
quoted
quoted
quoted
+ ret = sun50i_r329_ledc_resume(dev);
+ if (ret)
+ return ret;
You seem to fill the runtime_pm hooks, but only call them directly and
never enable runtime_pm on that device, is that intentional?
Yes. I did not want to delay the initial version by adding runtime PM
(and debugging the refcounts) when the driver already works now.
However, I had runtime/system PM in mind while writing the driver.
If you think it is too confusing, I could rename the functions to
something like sun50i_r329_ledc_hw_init / sun50i_r329_ledc_hw_exit.
It's not really the functions themselves that are confusing but rather
that you set them as runtime_pm hooks.
I do not set these functions as runtime PM hooks. SIMPLE_DEV_PM_OPS only sets
the system PM hooks, for "suspend to RAM and hibernation." Maybe you are
thinking of SET_RUNTIME_PM_OPS, which I do not use?
Ah, right, it's all good then, sorry for the noise
Maxime