On Fri, Nov 26, 2021 at 05:30:21PM +0800, allen-kh.cheng wrote:
Signed-off-by: Allen-KH Cheng <redacted>
With a minor comment:
Reviewed-by: Tzung-Bi Shih <redacted>
quoted hunk
diff --git a/drivers/mailbox/Kconfig b/drivers/mailbox/Kconfig
index c9fc06c7e685..c44a0102585d 100644
--- a/drivers/mailbox/Kconfig
+++ b/drivers/mailbox/Kconfig
@@ -226,6 +226,13 @@ config STM32_IPCC
with hardware for Inter-Processor Communication Controller (IPCC)
between processors. Say Y here if you want to have this support.
+config MTK_ADSP_IPC_MBOX
+ tristate "MediaTek ADSP Mailbox Controller"
+ depends on ARCH_MEDIATEK || COMPILE_TEST
+ help
+ Say yes here to add support for MediaTek ADSP IPC mailbox controller
+ driver. It is used to send short messages between processors with dsp.
+
config MTK_CMDQ_MBOX
tristate "MediaTek CMDQ Mailbox Support"
depends on ARCH_MEDIATEK || COMPILE_TEST
diff --git a/drivers/mailbox/Makefile b/drivers/mailbox/Makefile
index c2089f04887e..13d5c81852ca 100644
--- a/drivers/mailbox/Makefile
+++ b/drivers/mailbox/Makefile
@@ -49,6 +49,8 @@ obj-$(CONFIG_TEGRA_HSP_MBOX) += tegra-hsp.o
obj-$(CONFIG_STM32_IPCC) += stm32-ipcc.o
+obj-$(CONFIG_MTK_ADSP_IPC_MBOX) += mtk-adsp-mailbox.o
+
obj-$(CONFIG_MTK_CMDQ_MBOX) += mtk-cmdq-mailbox.o
To be neat, Kconfig name should be aligned to the file name.
That is, either:
- s/MTK_ADSP_IPC_MBOX/MTK_ADSP_MBOX/
- s/mtk-adsp-mailbox.o/mtk-adsp-ipc-mailbox.o/