Re: [PATCH net-next v3 0/9] net: add a helpers for loading netdev->dev_addr from FW
From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-10-07 13:00:17
Also in:
netdev
Hello: This series was applied to netdev/net-next.git (refs/heads/master) by David S. Miller [off-list ref]: On Wed, 6 Oct 2021 18:06:53 -0700 you wrote:
We're trying to make all writes to netdev->dev_addr go via helpers. A lot of places pass netdev->dev_addr to of_get_ethdev_address() and device_get_ethdev_addr() so this set adds new functions which wrap the functionality. v2 performs suggested code moves, adds a couple additional clean ups on the device property side, and an extra patch converting drivers which can benefit from device_get_ethdev_address(). [...]
Here is the summary with links:
- [net-next,v3,1/9] of: net: move of_net under net/
https://git.kernel.org/netdev/net-next/c/e330fb14590c
- [net-next,v3,2/9] of: net: add a helper for loading netdev->dev_addr
https://git.kernel.org/netdev/net-next/c/d466effe282d
- [net-next,v3,3/9] ethernet: use of_get_ethdev_address()
https://git.kernel.org/netdev/net-next/c/9ca01b25dfff
- [net-next,v3,4/9] device property: move mac addr helpers to eth.c
https://git.kernel.org/netdev/net-next/c/433baf0719d6
- [net-next,v3,5/9] eth: fwnode: change the return type of mac address helpers
https://git.kernel.org/netdev/net-next/c/8017c4d8173c
- [net-next,v3,6/9] eth: fwnode: remove the addr len from mac helpers
https://git.kernel.org/netdev/net-next/c/0a14501ed818
- [net-next,v3,7/9] eth: fwnode: add a helper for loading netdev->dev_addr
https://git.kernel.org/netdev/net-next/c/d9eb44904e87
- [net-next,v3,8/9] ethernet: use device_get_ethdev_address()
https://git.kernel.org/netdev/net-next/c/b8eeac565b16
- [net-next,v3,9/9] ethernet: make more use of device_get_ethdev_address()
https://git.kernel.org/netdev/net-next/c/894b0fb09215
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html