Hi Rob,
These patches are a v2 RFC for a devicetree binding of MCTP-over-I2C
hardware, where MCTP messages are transferred as SMBus block writes.
Since v1 I've revised the description and commits to hopefully be
clearer, and renamed the binding to indicate that it's generic for any
I2C hardware. That should allow for any later device specific drivers -
please let me know if I'm misunderstanding how it should be changed.
Cheers,
Matt
v2:
- Rename to mctp-i2c-generic rather than mctp-i2c
- Fix mux example to be correct and pass checks
- Set additionalProperties: false
- Commit message of patch 2/2 revised for clarity
- The I2C_OWN_SLAVE_ADDRESS flag is mentioned in reference to
i2c.txt where it is defined.
Matt Johnston (2):
dt-bindings: net: New binding for mctp-i2c-generic
dt-bindings: net: mctp-i2c-generic: support muxes
.../bindings/net/mctp-i2c-generic.yaml | 89 +++++++++++++++++++
1 file changed, 89 insertions(+)
create mode 100644 Documentation/devicetree/bindings/net/mctp-i2c-generic.yaml
--
2.30.2