Re: [PATCH v6 04/34] dt-bindings: Add bindings for Keem Bay IPC driver
From: Alessandrelli, Daniele <hidden>
Date: 2021-04-21 15:29:33
Also in:
lkml
On Wed, 2021-04-21 at 09:05 -0500, Jassi Brar wrote:
On Wed, Apr 21, 2021 at 8:55 AM mark gross [off-list ref] wrote:quoted
On Tue, Apr 20, 2021 at 03:14:59PM -0700, mark gross wrote:quoted
On Mon, Apr 12, 2021 at 04:24:41PM -0500, Jassi Brar wrote:quoted
On Mon, Mar 8, 2021 at 2:20 PM mark gross [off-list ref] wrote:quoted
On Fri, Mar 05, 2021 at 03:01:40PM -0600, Rob Herring wrote:quoted
On Fri, Feb 12, 2021 at 02:22:34PM -0800, mgross@linux.intel.com wrote:quoted
From: Daniele Alessandrelli <redacted> Add DT binding documentation for the Intel Keem Bay IPC driver, whichBindings are for h/w blocks, not drivers. From a binding perspective, I don't really care what the driver architecture for some OS looks like. I continue to not understand what this h/w looks like. A block diagram would help as would understanding what blocks have multiple clients (mailboxes and xlink in particular).I'm working to gather this info.Do I pick the mailbox related patches (and which ones exactly) ?v6-0002-dt-bindings-mailbox-Add-Intel-VPU-IPC-mailbox-bin.patch and v6-0003-mailbox-vpu-ipc-mailbox-Add-support-for-Intel-VPU.patchSorry for the confusion and delay. It seems there are some internal requests to change the name of this part of the VPU driver stack to avoid possible future namespace collisions. We will rename the vpu-ipc-mailbox with something more specific to KMB on the next posting. That looks like will have to be against v5.13-rc1 at this point. Sigh.Ok, I will dequeue the patches.
I actually have the renamed driver ready (the new name is keembay-ipc- mailbox, to align it with the other drivers in the series). Jassi, I can send the two updated patches as a separate patchset if you have time to re-review them and, in case pick them. Would that be okay with you? Or is it too late for that?
-j