Thread (10 messages) flat view 10 messages, 4 authors, 2021-03-03

Re: [PATCH v2 2/2] arm64: dts: fsl: add support for Kontron pitx-imx8m board

From: Heiko Thiery <hidden>
Date: 2021-03-03 17:11:41
Also in: linux-arm-kernel, lkml

Hi Fabio,


Am Di., 2. März 2021 um 15:43 Uhr schrieb Fabio Estevam [off-list ref]:
Hi Heiko,

On Mon, Feb 22, 2021 at 11:08 AM Heiko Thiery [off-list ref] wrote:
quoted
+       reg_usdhc2_vmmc: regulator-v-3v3-sd {
reg_usdhc2_vmmc: regulator-usdhc2-vmmc {
I used the same name as used on imx8mq-evk. Do you think a better name
is the one you proposed?
quoted
+       tpm_reset: tpm-reset {
+               compatible = "gpio-reset";
I don't see this compatible string documented.
This comes from the linux-imx tree [1].  Nethertheless the reset seems
not to be used by the tpm driver for the infineon chip.

[1] https://source.codeaurora.org/external/imx/linux-imx/tree/drivers/reset/gpio-reset.c?h=imx_5.4.70_2.3.0

So I think I can remove it here.
quoted
+               reset-gpios = <&gpio3 2 GPIO_ACTIVE_LOW>;
+               reset-delay-us = <2>;
+               reset-post-delay-ms = <60>;
+               #reset-cells = <0>;
+       };
+
+       usb_hub_reset: usb-hub-reset {
+               compatible = "gpio-reset";
Same here.
Also the usb-hub-reset can be removed.
quoted
+&fec1 {
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_fec1>;
+       phy-mode = "rgmii-id";
+       phy-handle = <&ethphy0>;
+       phy-reset-gpios = <&gpio1 11 GPIO_ACTIVE_LOW>;
This property is deprecated. Please consider using reset-gpios inside
ethernet-phy instead.
Done
quoted
+       /* TODO: configure audio, as of now just put a placeholder */
+       wm8904: audio-codec@1a {
+               compatible = "wlf,wm8904";
+               reg = <0x1a>;
+               clocks = <&clk IMX8MQ_CLK_SAI2_ROOT>;
+               clock-names = "mclk";
+               clock-frequency = <24000000>;
Not a valid property.
The whole node is removed since v3.
quoted
+/* M.2 B-key slot */
+&pcie0 {
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_pcie0>;
+       disable-gpio = <&gpio5 29 GPIO_ACTIVE_LOW>;
Not a valid property.
This comes from the linux-imx tree [2]. but in mainline it is not
valid. So I will remove it.

[2] https://source.codeaurora.org/external/imx/linux-imx/tree/drivers/pci/controller/dwc/pci-imx6.c?h=imx_5.4.70_2.3.0#n2436
quoted
+       reset-gpio = <&gpio1 9 GPIO_ACTIVE_LOW>;
+       clocks = <&clk IMX8MQ_CLK_PCIE1_ROOT>,
+                <&clk IMX8MQ_CLK_PCIE1_AUX>,
+                <&clk IMX8MQ_CLK_PCIE1_PHY>,
+                <&pcie0_refclk>;
+       clock-names = "pcie", "pcie_aux", "pcie_phy", "pcie_bus";
+       ext_osc = <1>;
Not a valid property.
This comes from the linux-imx tree [3]. but in mainline it is not
valid. So I will remove it.

[3] https://source.codeaurora.org/external/imx/linux-imx/tree/drivers/pci/controller/dwc/pci-imx6.c?h=imx_5.4.70_2.3.0#n2422
quoted
+/* Intel Ethernet Controller I210/I211 */
+&pcie1 {
+       clocks = <&clk IMX8MQ_CLK_PCIE2_ROOT>,
+                <&clk IMX8MQ_CLK_PCIE2_AUX>,
+                <&clk IMX8MQ_CLK_PCIE2_PHY>,
+                <&pcie1_refclk>;
+       clock-names = "pcie", "pcie_aux", "pcie_phy", "pcie_bus";
+       ext_osc = <1>;
Not a valid property.
same as commented before.

Thank you for the review. I will prepare v4.


--
Heiko
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help