Re: [PATCH v4 3/6] pinctrl: mediatek: avoid virtual gpio trying to set reg
From: Yingjoe Chen <hidden>
Date: 2020-03-25 09:22:35
Also in:
linux-mediatek, lkml
On Wed, 2020-03-25 at 16:12 +0800, Hanks Chen wrote:
for virtual gpios, they should not do reg setting and should behave as expected for eint function. Change-Id: I913501f21c841c2cb981530cd387395648f83984
Please remove Change-Id:
quoted hunk ↗ jump to hunk
Signed-off-by: Hanks Chen <redacted> Signed-off-by: Mars Cheng <redacted> --- drivers/pinctrl/mediatek/pinctrl-mtk-common-v2.c | 28 ++++++++++++++++++++++ drivers/pinctrl/mediatek/pinctrl-mtk-common-v2.h | 1 + drivers/pinctrl/mediatek/pinctrl-paris.c | 7 ++++++ 3 files changed, 36 insertions(+)diff --git a/drivers/pinctrl/mediatek/pinctrl-mtk-common-v2.c b/drivers/pinctrl/mediatek/pinctrl-mtk-common-v2.c index 20e1c89..087d233 100644 --- a/drivers/pinctrl/mediatek/pinctrl-mtk-common-v2.c +++ b/drivers/pinctrl/mediatek/pinctrl-mtk-common-v2.c@@ -226,6 +226,31 @@ static int mtk_xt_find_eint_num(struct mtk_pinctrl *hw, unsigned long eint_n) return EINT_NA; } +/* + * Virtual GPIO only used inside SOC and not being exported to outside SOC. + * Some modules use virtual GPIO as eint (e.g. pmif or usb). + * In MTK platform, external interrupt (EINT) and GPIO is 1-1 mapping + * and we can set GPIO as eint. + * But some modules use specific eint which doesn't have real GPIO pin. + * So we use virtual GPIO to map it. + */ + +bool mtk_is_virt_gpio(struct mtk_pinctrl *hw, unsigned int gpio_n) +{ + const struct mtk_pin_desc *desc; + bool virt_gpio = false; + + if (gpio_n >= hw->soc->npins) + return virt_gpio; + + desc = (const struct mtk_pin_desc *)&hw->soc->pins[gpio_n]; + + if (desc->funcs && !desc->funcs[desc->eint.eint_m].name) + virt_gpio = true;
I think removing virt_gpio and just return true/false for this function will make it easier to read. Joe.C
+ + return virt_gpio; +}