Thread (12 messages) 12 messages, 3 authors, 2020-04-09

Re: [PATCH 2/2] arm64: dts: qcom: sc7180: Add Coresight support

From: Stephen Boyd <hidden>
Date: 2020-03-21 22:10:56
Also in: linux-arm-msm, lkml

Quoting Sai Prakash Ranjan (2020-03-20 00:44:29)
Add coresight components found on Qualcomm SC7180 SoC.

Signed-off-by: Sai Prakash Ranjan <redacted>
---
Reviewed-by: Stephen Boyd <redacted>
Tested-by: Stephen Boyd <redacted>

One nit below.
quoted hunk ↗ jump to hunk
 arch/arm64/boot/dts/qcom/sc7180.dtsi | 507 +++++++++++++++++++++++++++
 1 file changed, 507 insertions(+)
diff --git a/arch/arm64/boot/dts/qcom/sc7180.dtsi b/arch/arm64/boot/dts/qcom/sc7180.dtsi
index 998f101ad623..d8fe960d6ace 100644
--- a/arch/arm64/boot/dts/qcom/sc7180.dtsi
+++ b/arch/arm64/boot/dts/qcom/sc7180.dtsi
@@ -1294,6 +1294,513 @@
                        };
                };
 
+               stm@6002000 {
+                       compatible = "arm,coresight-stm", "arm,primecell";
+                       reg = <0 0x06002000 0 0x1000>,
+                             <0 0x16280000 0 0x180000>;
+                       reg-names = "stm-base", "stm-stimulus-base";
+
+                       clocks = <&aoss_qmp>;
+                       clock-names = "apb_pclk";
+
+                       out-ports {
+                               port {
+                                       stm_out: endpoint {
+                                               remote-endpoint =
+                                                 <&funnel0_in7>;
Given that this is DT I'd say we just put this remote-endpoint all on
one line. Makes it more readable and I don't think we really care about
the line length in these cases. We're nested pretty deep because it's a
graph binding.
+                                       };
+                               };
+                       };
+               };
+
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help