Re: [PATCH v6 5/6] media: rkvdec: Add the rkvdec driver
From: Boris Brezillon <boris.brezillon@collabora.com>
Date: 2020-03-02 14:35:36
Also in:
linux-media, linux-rockchip, lkml
From: Boris Brezillon <boris.brezillon@collabora.com>
Date: 2020-03-02 14:35:36
Also in:
linux-media, linux-rockchip, lkml
On Mon, 2 Mar 2020 14:57:46 +0100 Mauro Carvalho Chehab [off-list ref] wrote:
quoted
+ for (j = 0; j < 3; j++) {Again a magic number. I guess this came from that big "M_N" table with 4 elements, right? Please use a define instead of hardcoding a number here.
Nope, it's unrelated to the cabac_table size, it's related to how the HW accesses the P/B reflists (there are 1 P reflist, and 2 B reflists, hence the 3 here). I guess we can have a '#define NUM_REFLISTS 3'.