Re: [PATCH v3 2/4] clk: qcom: clk-rpmh: Convert to parent data scheme
From: Vinod Koul <vkoul@kernel.org>
Date: 2019-08-26 06:22:40
Also in:
linux-arm-msm, linux-clk, lkml
From: Vinod Koul <vkoul@kernel.org>
Date: 2019-08-26 06:22:40
Also in:
linux-arm-msm, linux-clk, lkml
On 23-08-19, 23:31, Bjorn Andersson wrote:
On Thu 22 Aug 10:01 PDT 2019, Vinod Koul wrote:quoted
Convert the rpmh clock driver to use the new parent data scheme by specifying the parent data for board clock. Signed-off-by: Vinod Koul <vkoul@kernel.org> --- drivers/clk/qcom/clk-rpmh.c | 10 ++++++++-- 1 file changed, 8 insertions(+), 2 deletions(-)diff --git a/drivers/clk/qcom/clk-rpmh.c b/drivers/clk/qcom/clk-rpmh.c index c3fd632af119..0bced7326a20 100644 --- a/drivers/clk/qcom/clk-rpmh.c +++ b/drivers/clk/qcom/clk-rpmh.c@@ -95,7 +95,10 @@ static DEFINE_MUTEX(rpmh_clk_lock); .hw.init = &(struct clk_init_data){ \ .ops = &clk_rpmh_ops, \ .name = #_name, \ - .parent_names = (const char *[]){ "xo_board" }, \ + .parent_data = &(const struct clk_parent_data){ \ + .fw_name = "xo_board", \ + .name = "xo_board", \Iiuc .name here refers to the global clock namespace and .fw_name refers to the device_node local name space. As such I really prefer this to be: .fw_name = "xo", .name = "xo_board", This ensures the backwards compatibility (when using global lookup), without complicating the node-local naming.
Sure, while thinking more on this, should we finalize the name as xo or cxo, I see latter being also used at few places. It would be great to get a name and stick to it for longer time :) -- ~Vinod