Thread (17 messages) 17 messages, 4 authors, 2019-06-12

Re: [PATCH v4 00/10] Rename Rockchip VPU driver to Hantro, add initial i.MX8M support

From: Boris Brezillon <boris.brezillon@collabora.com>
Date: 2019-06-12 08:30:32
Also in: linux-media

On Wed, 12 Jun 2019 10:00:45 +0200
Hans Verkuil [off-list ref] wrote:
On 6/12/19 9:55 AM, Hans Verkuil wrote:
quoted
On 6/11/19 2:50 PM, Philipp Zabel wrote:  
quoted
There are several other SoCs that contain Hantro IP based VPUs, such as
NXP i.MX8MQ (Hantro G1 and G2) and i.MX8MM (Hantro G1, G2, and H1). To
maximize code sharing, add initial support for these SoCs to the
Rockchip VPU driver, after renaming it to Hantro VPU.

This series is based on the br-v5.3g tag, commit e568d2cc1ef6
("rockchip/vpu: Add support for MPEG-2 decoding on RK3288") with
https://patchwork.linuxtv.org/patch/56402/ ("rockchip/vpu: Add support
for MPEG-2 decoding on RK3328") applied on top. It supports MPEG-2
decoding on i.MX8MQ. MPEG-2 decoding and JPEG encoding on i.MX8MM may
or may not work, I don't have the hardware to test.

Changes since v3:
 - Split rk3288_vpu_regs.h into hantro_g1_regs.h and hantro_h1_regs.h,
   rename VDPU register defines to G1 and VEPU register defines to H1.
 - Make Rockchip / i.MX8M support configurable.
 - Keep staging/media Kconfig in alphabetic order.
 - Rename bases to reg_bases
 - Move dynamic clocks before i.MX8M support.  
Can you please rebase this on top of the media_tree master? This series
doesn't apply there.

I'd like to get this rename series in asap since keeping this out-of-tree
is a pain.

It looks in good shape in general.  
In fact, I would like to hold off on applying any other rockchip patches
until this is in (and that means any pending rockchip patches probably
need rebasing).
Ack. Actually, Ezequiel and I are waiting for this series to land
before sending new patches, so that'd be nice to have at least patches
1 to 7 applied really soon.
So if a v5 applies cleanly and doesn't throw up new sparse/smatch issues,
then I'll take it.
Great!
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help