Thread (31 messages) flat view 31 messages, 4 authors, 2017-07-27

Re: [PATCH 01/11] net: phy: Add rockchip phy driver support

From: David.Wu <hidden>
Date: 2017-06-27 14:44:48
Also in: linux-arm-kernel, linux-rockchip, lkml, netdev

Hi Andrew,

在 2017/6/24 10:19, Andrew Lunn 写道:
On Fri, Jun 23, 2017 at 12:41:59PM +0800, David Wu wrote:
quoted
Support internal ephy currently.

Signed-off-by: David Wu <redacted>
---
  drivers/net/phy/Kconfig    |  4 ++
  drivers/net/phy/Makefile   |  1 +
  drivers/net/phy/rockchip.c | 94 ++++++++++++++++++++++++++++++++++++++++++++++
  3 files changed, 99 insertions(+)
  create mode 100644 drivers/net/phy/rockchip.c
diff --git a/drivers/net/phy/Kconfig b/drivers/net/phy/Kconfig
index c360dd6..86010d4 100644
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -350,6 +350,10 @@ config XILINX_GMII2RGMII
           the Reduced Gigabit Media Independent Interface(RGMII) between
           Ethernet physical media devices and the Gigabit Ethernet controller.
  
+config ROCKCHIP_MAC_PHY
This is a bit of an odd name, having both MAC and PHY in it. Are there
any other RockChip PHYs? Any external PHYS? Are they register
incompatible with the internal PHY?  Is it even RockChip IP? Or has it
been licensed from somebody else?
Maybe I just want to highlight it applies to the PHY with Mac 
connection, actually I was named Rockchip at the beginning, as Heiko 
said, PHY is a wide range, so add a modifier to restrict it.

Yes, we use other external phys, like realtek and etc...

If we have any other phy in our socs, it also could be expanded at 
rockchip_phy_tbl{} at rockchip.c

it has been licensed from somebody.
I would more likely just call it ROCKCHIP_PHY.

   Andrew

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help