On 2017-05-24 23:23, Shawn Guo wrote:
On Thu, May 25, 2017 at 05:04:58AM +0000, A.S. Dong wrote:
quoted
If we really want to change, 'IMX7ULP1' may be a little strange as 'IMX7ULP' is
the official external name and all other places are using it.
So IMX7ULP may be more suitable.
Yes, I actually meant IMX7ULP, which matches how we name the SoC
elsewhere in the kernel.
All the other arch/arm/boot/dts/imx*pinfunc.h use MX7ULP (without the
I), but I am fine with either one.
--
Stefan
quoted
Then next generation may be:
IMX7ULP0_PAD_PTC0_PTC0.
Vs
IMX7ULP_PAD_PTC0_PTC0
Just not much better than:
ULP1_PAD_PTC0_PTC0.
vs
ULP0_PAD_PTC0_PTC0
That's why I did not do it initially.
However, if you do want the change, i'm okay to do it.
For the next generation, we will have a name for it in the kernel
anyway. The pinctrl macro simply follows that name.
Shawn