Re: [PATCH v3 1/2] ARM: dts: da850-lcdk: add the dumb-vga-dac node
From: Bartosz Golaszewski <hidden>
Date: 2016-12-06 15:06:45
Also in:
dri-devel, linux-arm-kernel, lkml
2016-12-06 16:03 GMT+01:00 Sekhar Nori [off-list ref]:
On Tuesday 06 December 2016 06:32 PM, Bartosz Golaszewski wrote:quoted
2016-12-05 13:49 GMT+01:00 Tomi Valkeinen [off-list ref]:quoted
On 29/11/16 13:57, Bartosz Golaszewski wrote:quoted
Add the dumb-vga-dac node to the board DT together with corresponding ports and vga connector. This allows to retrieve the edid info from the display automatically.It's a bit difficult to follow this as there's been so many patches going around. But I take the above is the LCDC node in the base da850 dtsi file? In that case, what is the display_in supposed to present? It's the first node in the "display chain", so it has no input. Also, don't touch da850.dtsi here, just add the "ports" node in the da850-lcdk.dts file. If the da850.dtsi has not been merged yet, I'd change the name of the lcdc node to something else than "display". It's rather vague. If it's named "lcdc", reading da850-lcdk.dts becomes much easier, as you'll refer to "lcdc".The node is already in Sekhar's branch.The node name should be 'display' as thats the ePAPR 1.1 generic name recommendation. The label is also set to 'display' though and that can be changed to lcdc. A pre-patch to fix that before we modify the node further is welcome. Thanks, Sekhar
I'll include this in v5 together with the change requested by Laurent. Thanks, Bartosz _______________________________________________ dri-devel mailing list dri-devel@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/dri-devel