Thread (3 messages) flat view 3 messages, 2 authors, 2016-12-01

Re: [PATCH v4] clkdev: add devm_of_clk_get()

From: Kuninori Morimoto <hidden>
Date: 2016-12-01 01:56:36
Also in: alsa-devel, linux-arm-kernel, linux-clk, lkml

Hi Stephen
quoted
Current Linux has of_clk_get(), but doesn't have devm_of_clk_get().
This patch adds it. It is implemeted in clk-devres.c to share
devm_clk_release().
Please add an explanation of why we want this sort of API. The
example you gave for audio sound card is useful. We're not going
to remember 5 months from now why we did something, so we should
put that here instead of digging through mailing list archives.
OK, will do
quoted
+struct clk *devm_of_clk_get(struct device *dev,
+			    struct device_node *np, int index)
Please call this devm_get_clk_from_child() instead. Also, replace
the index argument with a string called con_id. Then call
of_clk_get_by_name() instead of of_clk_get().
I guess we want to have _of_ on function name ?

  devm_get_clk_from_child() ?
  devm_of_get_clk_from_child ?

Best regards
---
Kuninori Morimoto
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help