Thread (1 message) 1 message, 1 author, 2016-08-16

Re: RFC: board dts-file naming scheme

From: Rob Herring <hidden>
Date: 2016-08-16 16:43:40

On Tue, Aug 16, 2016 at 10:13 AM, Antony Pavlov [off-list ref] wrote:
Hi all!

I have not found any recomendation on board dts-file naming scheme
in linux.git/Documentation/devicetree/.

ARM/ARM64 Linux mostly uses <soc-name>-<board-name>.dts board dts-file
naming scheme (also see slide "Adding the support for a new ARM board" from [1]).

   arch/arm/boot/dts/am335x-baltos-ir5221.dts
   arch/arm/boot/dts/at91-ariag25.dts
   arch/arm/boot/dts/exynos5250-arndale.dts
   arch/arm/boot/dts/imx6dl-gw54xx.dts
   arch/arm/boot/dts/sun9i-a80-cubieboard4.dts
   arch/arm/boot/dts/tegra30-colibri-eval-v3.dts
   arm64/boot/dts/qcom/apq8016-sbc.dts
   arm64/boot/dts/cavium/thunder-88xx.dts
   arm64/boot/dts/broadcom/ns2-svk.dts
   arm64/boot/dts/rockchip/rk3368-r88.dts
   arm64/boot/dts/mediatek/mt8173-evb.dts

MIPS Linux mostly uses <soc-name>_<board-name>.dts naming scheme:

   arch/mips/boot/dts/netlogic/xlp_gvp.dts
   arch/mips/boot/dts/qca/ar9132_tl_wr1043nd_v1.dts
   arch/mips/boot/dts/ralink/mt7620a_eval.dts

Can we elaborate some common rule on board dts-file naming scheme
and add it into linux.git/Documentation/devicetree/?
My guidance is follow what most other files in a given directory do.
In absence of that, use '-'.

If you want to add documentation, then I'll take it. I can tell you
that arm-soc maintainers are not going to take renames for things that
don't follow the documentation.

Rob
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help