Am 10.07.2016 um 02:19 schrieb Bjørn Mork:
Martin Blumenstingl [off-list ref] writes:
quoted
+ if (of_property_read_bool(np, "qca,clk-25mhz"))
+ ah->is_clk_25mhz = true;
+
+ if (of_property_read_bool(np, "qca,disable-2ghz"))
+ ah->disable_2ghz = true;
+
+ if (of_property_read_bool(np, "qca,disable-5ghz"))
+ ah->disable_5ghz = true;
This is bike-shedding, but how about
ah->is_clk_25mhz = of_property_read_bool(np, "qca,clk-25mhz");
ah->disable_2ghz = of_property_read_bool(np, "qca,disable-2ghz");
ah->disable_5ghz = of_property_read_bool(np, "qca,disable-5ghz");
instead?
Hm... i assume each WiFi hw in the world can reuse this settings, may be
it i worth to use generic names?
--
Regards,
Oleksij