On Sun, Jan 24, 2016 at 07:21:54PM +0000, Mans Rullgard wrote:
From: Andy Shevchenko <redacted>
There are several changes are done here:
- Convert the property to be in bytes
Much more convenient than keeping encoded value.
- Use one value for all AHB masters for now
It seems in practice we have no controllers where masters have different
data bus width, we still might return to distinct values when there is a use
case.
- Rename data_width to data-width in the device tree bindings.
- While here, replace dwc_fast_ffs() by __ffs().
Signed-off-by: Andy Shevchenko <redacted>
Signed-off-by: Mans Rullgard <redacted>
---
This patch changes the DT binding, so it should probably be amended for
compatibility with old device trees. I've included it as is since I think
the change as such is good.
Just because you update the dts files, it doesn't make the change okay.
I'm fine with the DT change, but the driver would have to support both
old and new property names. Doesn't really seem worth doing to me.
Rob
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at http://vger.kernel.org/majordomo-info.html