Thread (20 messages) 20 messages, 5 authors, 2015-09-17

Re: [PATCH RFC 6/8] drm: hisilicon: Add support for fbdev

From: Xinliang Liu <xinliang.liu@linaro.org>
Date: 2015-09-17 12:11:59
Also in: dri-devel

On 17 September 2015 at 19:52, Rob Clark [off-list ref] wrote:
On Wed, Sep 16, 2015 at 5:48 AM, Xinliang Liu [off-list ref]
wrote:
quoted

On 16 September 2015 at 02:25, Rob Herring [off-list ref] wrote:
Hi Rob, thanks a lot for reply:-)
quoted
On 09/15/2015 04:37 AM, Xinwei Kong wrote:
quoted
If you config DRM_HISI_FBDEV optional, this patch will only support
fbdev
mode while also supporting double buffer.
This is a lot of duplicated code from CMA fbdev. Is double buffering the
only reason why CMA fbdev can't be used or are there some other
constraints?
Yes, double buffering is the main reason we rewrite our own fbdev.
CMA fbdev only create one buffer. But we need at least  double buffer for
running Android with fbdev.
quoted
Double buffering in fbdev has always been a hack, so I'm
guessing that is not a feature that should be added here.
If so, I think it is hard to be accepted for my cma fbdev patch to
support
quoted
multi buffer.
This early week, I have sent a cma fbdev patch for supporting this. The
subject is
"[PATCH] drm/cma-helper: Add multi buffer support for cma fbdev".
We do have a strong will to support this feature. I described the reason
in
quoted
the patch. Please take a look for me. Thank you very much.
fwiw, drm_gralloc has support for kms.
We do have a plan to replace fbdev with kms. But it take time.

Currently it is expected to be
paired w/ a mesa gpu driver, which might not work for everyone, but I
suppose the display part of it could be extracted out for a
gralloc.kms.so for pure sw rendering.. that might be a better
approach.
Yes, I also think kms should be handle in hwc rather than in gralloc.
IMO, gralloc should just handle dma buffer alloc and free.
We have a reference hwc implementation. which will handle kms inside it.
wiki:
https://wiki.linaro.org/BenjaminGaignard/HWComposer_DRM?highlight=%28hwcomposer%2
source code: git://git.linaro.org/people/benjamin.gaignard/hwcomposer.git

Cheers,
-Xinliang

http://git.android-x86.org/?p=platform/hardware/drm_gralloc.git

BR,
-R
quoted
-Xinliang
quoted
Rob
quoted
Signed-off-by: Xinliang Liu <xinliang.liu@linaro.org>
Signed-off-by: Xinwei Kong <kong.kongxinwei@hisilicon.com>
Signed-off-by: Andy Green <redacted>
Signed-off-by: Jiwen Qi <redacted>
Signed-off-by: Yu Gong <redacted>
---
 drivers/gpu/drm/hisilicon/Kconfig              |  13 +
 drivers/gpu/drm/hisilicon/Makefile             |   3 +-
 drivers/gpu/drm/hisilicon/hisi_drm_connector.c |   4 +
 drivers/gpu/drm/hisilicon/hisi_drm_drv.c       |   9 +
 drivers/gpu/drm/hisilicon/hisi_drm_dsi.c       |  15 +
 drivers/gpu/drm/hisilicon/hisi_drm_fb.h        |   5 +
 drivers/gpu/drm/hisilicon/hisi_drm_fbdev.c     | 395
+++++++++++++++++++++++++
 drivers/gpu/drm/hisilicon/hisi_drm_fbdev.h     |  24 ++
 8 files changed, 467 insertions(+), 1 deletion(-)
 create mode 100644 drivers/gpu/drm/hisilicon/hisi_drm_fbdev.c
 create mode 100644 drivers/gpu/drm/hisilicon/hisi_drm_fbdev.h

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help