Re: [PATCH v4 1/2] pinctrl: Add driver for Alphascale asm9260 pinctrl
From: Linus Walleij <hidden>
Date: 2015-09-25 17:14:47
Also in:
linux-gpio, lkml
From: Linus Walleij <hidden>
Date: 2015-09-25 17:14:47
Also in:
linux-gpio, lkml
On Tue, Sep 8, 2015 at 10:55 PM, Oleksij Rempel [off-list ref] wrote:
[Me]quoted
Why is it necessary for the driver to copy one description of the pin into another?If i understand it correctly, pinctrl_pin_desc is essential part of pinmux framework. Theoretically i should define just statical array of this struct, but by this number of pins and functions it hard to keep it readable and error free. So i decided to create asm9260_mux_table which contains every thing i need. The side effect is higher memory usage since i need to create pinctrl_pin_desc on fly. May be i miss some thing?
I don't see how having code copying data from one data container to another makes things "more readable and error free". Go for *one* static definition. Also the memory waste is a total no-no. Yours, Linus Walleij