Dear Sebastian,
On Sun, 20 Sep 2015 21:32:37 +0200
Sebastian Hesselbarth [off-list ref] wrote:
quoted
+ BERLIN_PINCTRL_GROUP("SM_TDO", 0x0, 0x3, 0x12,
+ BERLIN_PINCTRL_FUNCTION(0x0, "sm_tdo"),
+ BERLIN_PINCTRL_FUNCTION(0x1, "sm_gpio2")),
+ BERLIN_PINCTRL_GROUP("SM_URT0_TXD", 0x0, 0x3, 0x15,
+ BERLIN_PINCTRL_FUNCTION(0x0, "sm_urt0_txd"),
Please avoid abbreviating acronyms even more, we can afford the
few extra bytes.
In the 2nd version, I kept using HW names, for example:
1. "urt0" as the function name,
2. "SM_URT0_TXD" as the pin name (group name)
to keep sync with HW, especially the pin names are the same as HW's, because
that's what HW doc, sch, etc. call them. IMHO, using a different name with HW
is not a good idea, what do you think?
Thanks,
Jisheng