On Jul 27, 2015 09:56, "James Liao" [off-list ref] wrote:
Hi Daniel,
On Fri, 2015-07-24 at 19:32 +0800, Daniel Kurtz wrote:
quoted
quoted
@@ -88,6 +88,13 @@
#clock-cells = <0>;
};
+ cpum_ck: dummy_clk {
I'm not a big fan of this "dummy_clk".
The 'name' part of the devicetree node is supposed to be generic.
So, perhaps just oscillator@2, and move it down below clk32k:
oscillator@1.
quoted
Otherwise:
cpum_ck is a test clock which only available in IC test. It's empty on
MT8173 evaluation or production boards. Should we name this kind of
empty clock as an oscillator? Or is there a better name for it?
When and if it is used, it would be an oscillator of some kind. It is only
"dummy" because it is not currently used.
I am not an expert, but I think these names should be generic, and
"oscillator" is consistent with what is used elsewhere in this file for off
chip clock sources.
-Dan
Best regards,
James