Re: [PATCH v7 00/14] crypto: add a new driver for Marvell's CESA
From: Stephen Rothwell <hidden>
Date: 2015-06-25 00:33:59
Subsystem:
crypto api, the rest · Maintainers:
Herbert Xu, "David S. Miller", Linus Torvalds
Hi Paul, On Wed, 24 Jun 2015 20:00:38 -0400 Paul Gortmaker [off-list ref] wrote:
[Re: [PATCH v7 00/14] crypto: add a new driver for Marvell's CESA] On 22/06/2015 (Mon 15:59) Herbert Xu wrote:quoted
On Mon, Jun 22, 2015 at 09:23:36AM +0200, Boris Brezillon wrote:quoted
Hi Herbert, On Sun, 21 Jun 2015 16:27:17 +0800 Herbert Xu [off-list ref] wrote:quoted
On Sun, Jun 21, 2015 at 10:24:18AM +0200, Boris Brezillon wrote:quoted
Indeed. Here is a patch fixing that.I think you should just kill COMPILE_TEST instead of adding ARM.The following patch is killing the COMPILE_TEST dependency.Patch applied.Just a heads up, this driver is still killing a couple of linux-next builds today and for the past few days. drivers/crypto/mv_cesa.c:1037:2: error: implicit declaration of function 'of_get_named_gen_pool' [-Werror=implicit-function-declaration] http://kisskb.ellerman.id.au/kisskb/buildresult/12448851/ http://kisskb.ellerman.id.au/kisskb/buildresult/12448776/ Missing dependency on CONFIG_OF_<blah> presumably.
Actually this is caused by patch "genalloc: rename of_get_named_gen_pool() to of_gen_pool_get()" from Andrew's series. I fixed one of the breakages, but clearly not all. I will add this patch to today's linux-next (Andrew, you will need this, obviously): From: Stephen Rothwell <redacted> Date: Thu, 25 Jun 2015 10:31:33 +1000 Subject: [PATCH] crypto: marvell/cesa - another fix up for of_get_named_gen_pool() rename Signed-off-by: Stephen Rothwell <redacted> --- drivers/crypto/mv_cesa.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/crypto/mv_cesa.c b/drivers/crypto/mv_cesa.c
index 5bcd575fa96f..e6b658faef63 100644
--- a/drivers/crypto/mv_cesa.c
+++ b/drivers/crypto/mv_cesa.c@@ -1034,8 +1034,8 @@ static int mv_cesa_get_sram(struct platform_device *pdev, &sram_size); cp->sram_size = sram_size; - cp->sram_pool = of_get_named_gen_pool(pdev->dev.of_node, - "marvell,crypto-srams", 0); + cp->sram_pool = of_gen_pool_get(pdev->dev.of_node, + "marvell,crypto-srams", 0); if (cp->sram_pool) { cp->sram = gen_pool_dma_alloc(cp->sram_pool, sram_size, &cp->sram_dma);
--
2.1.4
--
Cheers,
Stephen Rothwell sfr@canb.auug.org.auAttachments
- (unnamed) [application/pgp-signature] 819 bytes