Re: Re: [PATCH] mmc: core: add runtime-resume caps to support resume at runtime_resume
From: addy.ke@rock-chips.com <hidden>
Date: 2015-02-05 11:44:58
Sorry, I will resend patch right now From: Mark Rutland Date: 2015-02-05 19:27 To: Addy Ke CC: robh+dt@kernel.org; Pawel Moll; ijc+devicetree@hellion.org.uk; galak@codeaurora.org; rdunlap@infradead.org; tgih.jun@samsung.com; jh80.chung@samsung.com; chris@printf.net; ulf.hansson@linaro.org; dinguyen@altera.com; heiko@sntech.de; olof@lixom.net; dianders@chromium.org; sonnyrao@chromium.org; amstan@chromium.org; devicetree@vger.kernel.org; linux-doc@vger.kernel.org; linux-kernel@vger.kernel.org; linux-mmc@vger.kernel.org; linux-arm-kernel@lists.infradead.org; linux-rockchip@lists.infradead.org; zhenfu.fang@rock-chips.com; cf@rock-chips.com; lintao@rock-chips.com; chenfen@rock-chips.com; zyf@rock-chips.com; xjq@rock-chips.com; huangtao@rock-chips.com; zyw@rock-chips.com; yzq@rock-chips.com; hj@rock-chips.com; kever.yang@rock-chips.com; zhangqing@rock-chips.com; hl@rock-chips.com Subject: Re: [PATCH] mmc: core: add runtime-resume caps to support resume at runtime_resume On Thu, Feb 05, 2015 at 11:06:59AM +0000, Addy Ke wrote:
quoted hunk ↗ jump to hunk
Signed-off-by: Addy Ke <redacted> --- Documentation/devicetree/bindings/mmc/mmc.txt | 11 +++++++++++ drivers/mmc/core/host.c | 2 ++ 2 files changed, 13 insertions(+)diff --git a/Documentation/devicetree/bindings/mmc/mmc.txt b/Documentation/devicetree/bindings/mmc/mmc.txt index 438899e..303b448 100644 --- a/Documentation/devicetree/bindings/mmc/mmc.txt +++ b/Documentation/devicetree/bindings/mmc/mmc.txt@@ -40,9 +40,20 @@ Optional properties: - mmc-hs200-1_2v: eMMC HS200 mode(1.2V I/O) is supported - mmc-hs400-1_8v: eMMC HS400 mode(1.8V I/O) is supported - mmc-hs400-1_2v: eMMC HS400 mode(1.2V I/O) is supported +- runtime-resume: resume at runtime_resume is supported
This reads like description of Linux internals (runtime_resume), which shouldn't be in the DT. What does this mean at the HW level? I'm sure we can find a better name for this, or another way of describing this.
- dsr: Value the card's (optional) Driver Stage Register (DSR) should be programmed with. Valid range: [0 .. 0xffff]. +Card power and reset control: +The following properties can be specified for cases where the MMC +peripheral needs additional reset, regulator and clock lines. It is for +example common for WiFi/BT adapters to have these separate from the main +MMC bus: + - card-reset-gpios: Specify GPIOs for card reset (reset active low) + - card-external-vcc-supply: Regulator to drive (independent) card VCC + - clock with name "card_ext_clock": External clock provided to the card
Are these proeprties placed on the MMC controller node, or a sub-node representing the card/slot? Thanks, Mark.