Re: [PATCH v4 1/5] xhci: add a quirk for device disconnection errata for Synopsis Designware USB3 core
From: Sneeker Yeh <hidden>
Date: 2015-02-18 14:39:53
From: Sneeker Yeh <hidden>
Date: 2015-02-18 14:39:53
Hi, 2015/2/18 下午10:34 於 "Felipe Balbi" [off-list ref] 寫道:
On Wed, Feb 18, 2015 at 10:47:45AM +0200, Mathias Nyman wrote:quoted
Hi This looks correct, but if you are still going to make a new series
fixing
quoted
Felipe's comments then the following tiny nitpicks could be fixed as
well.
quoted
Otherwise Acked-by: Mathias Nyman <redacted> Felipe, Do you want to take this series through your tree?I can, no issues :-)quoted
On 17.02.2015 07:41, Sneeker Yeh wrote:quoted
+static void xhci_try_to_clear_csc(struct usb_hcd *hcd, int
dev_port_num)
quoted
Either add a function description explaining something like "Late clearing of connect status. Some quirky hardware will suspend the controller when CSC bit is cleared and leave URBs unhandled" Or change the function name to something like xhci_late_csc_clear_quirk() or xhci_deferred_csc_clear_quirk()I have a feeling xhci_late_csc_clear_quirk() is a better name, much more descriptive than xhci_try_to_clear_csc() :-)
Hmm, I'll use this one, ^^ Thanks for comment it. Much appreciate, Sneeker
-- balbi