Re: [resend PATCH v3 2/4] Documentation: dt-bindings: add dt binding info for hi6220
From: Sergei Shtylyov <hidden>
Date: 2015-02-10 11:37:01
Also in:
linux-arm-kernel
Hello. On 2/10/2015 12:10 PM, Zhangfei Gao wrote:
Signed-off-by: Zhangfei Gao <redacted> --- .../devicetree/bindings/usb/hi6220-usb.txt | 49 ++++++++++++++++++++++ 1 file changed, 49 insertions(+) create mode 100644 Documentation/devicetree/bindings/usb/hi6220-usb.txt
quoted hunk
diff --git a/Documentation/devicetree/bindings/usb/hi6220-usb.txt b/Documentation/devicetree/bindings/usb/hi6220-usb.txt new file mode 100644 index 0000000..b8278de --- /dev/null +++ b/Documentation/devicetree/bindings/usb/hi6220-usb.txt@@ -0,0 +1,49 @@ +Hisilicon hi6220 SoC USB controller +-----------------------------
[...]
+PHY: +----- + +Required properties: +- compatible: "hisilicon,hi6220-usb-phy" +- vcc-supply: phandle to the regulator that provides power to the PHY. +- clocks: phandle and clock specifier of the PHY clock. +- hisilicon,peripheral-syscon: phandle of syscon used to control peripheral. +- hisilicon,gpio-vbus: gpio of detecting vbus. +- hisilicon,gpio-id: gpio of detecting id.
Actually, GPIO bindings say that GPIO properties should be named
"[<name>-]gpios".
+
+Example:
+
+ peripheral_ctrl: syscon@f7030000 {
+ compatible = "syscon";
+ reg = <0x0 0xf7030000 0x0 0x1000>;
+ };
+
+ usb2_phy: usbphy {
Please name it "usb-phy" as it better resembles "ethernet-phy"
standardized by ePAPR.
[...]
WBR, Sergei
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at http://vger.kernel.org/majordomo-info.html