On Tue 16 Dec 17:15 PST 2014, Stephen Boyd wrote:
On 12/08/2014 04:22 PM, Bjorn Andersson wrote:
[..]
quoted
+- qcom,current-limit: mA; per-string current limit; value from 0 to 25
+ default: 20mA
+- qcom,current-boost-limit: mA; boost current limit; one of:
+ 105, 385, 525, 805, 980, 1260, 1400, 1680
+ default: 805mA
[..]
quoted
+- qcom,ovp: V; Over-voltage protection limit; one of:
+ 27, 29, 32, 35
+ default: 29V
It would be nice if the units were part of the property name, i.e.
qcom,ovp-V, qcom,current-boost-limit-mA, etc. That way the units are
known without having to refer to the documentation.
That might be useful, on the other hand one probably need to look inte bindings
docs to figure out valid values anyways.
quoted
+- qcom,num-strings: #; number of led strings attached; value from 1 to 3
+ default: 2
I wonder if qcom,#strings is more appropriate?
Checking the other docs indicate that it's far more common to use num- than #
here, but I haven't found anything written about it - it's more common to name
this just "qcom,strings" than "qcom,#strings" at least...
Regards,
Bjorn