On Wed, Nov 05, 2014 at 08:46:58PM +0100, Robert Jarzmik wrote:
Felipe Balbi [off-list ref] writes:
quoted
Hi,
On Sun, Nov 02, 2014 at 07:11:49PM +0100, Robert Jarzmik wrote:
quoted
In order to prepare device-tree conversion, port gpio_vbus to use
gpio_desc.
Signed-off-by: Robert Jarzmik <redacted>
Can we just convert users of this to a phy-generic.c with a regulator ?
Maybe, let's see what is missing.
quoted
This is basically what gpio-vbus is doing, it's basically a regulator.
And a detector too. The basic thing is that it request an interrupt, and upon
this interrupt it schedules through a workqueue a usb_gadget_vbus_connect() and
the regulator stuff.
I don't see the interrupt+ usb_gadget_vbus_connect() stuff that in the
phy-generic. Am I missing something ?
Well, let's add that :-) Just make it optional. It's pointless to have
80% duplicated code just because of 20% missing in phy-generic :-)
Then we avoid adding gpio-vbus specific DT properties too.
--
balbi