Thread (1 message) 1 message, 1 author, 2014-10-07

Re: [PATCH v2] Input: add i2c/smbus driver for elan touchpad

From: 'Dmitry Torokhov' <hidden>
Date: 2014-10-07 01:24:37

Hi Duson,

On Tue, Oct 07, 2014 at 09:15:26AM +0800, duson wrote:
Hi Dmitry,
quoted
-----Original Message-----
From: Dmitry Torokhov [mailto:dmitry.torokhov-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org]
Sent: Tuesday, October 07, 2014 12:37 AM
To: Mark Rutland
Cc: Duson Lin; linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org; linux-input-u79uwXL29TY76Z2rM5mHXA@public.gmane.org;
bleung-F7+t8E8rja9g9hUCZPvPmw@public.gmane.org; agnescheng-F7+t8E8rja9g9hUCZPvPmw@public.gmane.org; phoenix-9cfG7bMpBgR9nmWX13WWKA@public.gmane.org;
jeff.chuang-9cfG7bMpBgR9nmWX13WWKA@public.gmane.org; devicetree-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
Subject: Re: [PATCH v2] Input: add i2c/smbus driver for elan touchpad

On Mon, Oct 06, 2014 at 10:24:52AM +0100, Mark Rutland wrote:
quoted
On Fri, Oct 03, 2014 at 10:06:51PM +0100, Dmitry Torokhov wrote:
quoted
[adding devicetree folks...]

On Fri, Oct 03, 2014 at 02:03:57PM -0700, Dmitry Torokhov wrote:
quoted
diff --git a/Documentation/devicetree/bindings/input/elan_i2c.txt
b/Documentation/devicetree/bindings/input/elan_i2c.txt
quoted
quoted
quoted
new file mode 100644
index 0000000..0a6ee7d
--- /dev/null
+++ b/Documentation/devicetree/bindings/input/elan_i2c.txt
@@ -0,0 +1,34 @@
+Elantech I2C Touchpad
+
+Required properties:
+- compatible: must be "elan,i2c_touchpad".
s/_/-/ in DT strings and property names plase.

The name seems very generic, and you mention the driver supports a
variety of touchpads. Please choose a specific device name for the
compatible string. Other devices can have that as a fallback entry in
addition to a more specific string.
Duson, what would be a good model/device name here?
Hmm....maybe we can rename this device name like our touch screen team
elan_i2c --> elantp_i2c
How do you feel about this.
It does not really add any additional info: elan,i2c_touchpad vs
elan,elantp_i2c. What we need is a model/family name. Something like
elan,ekt2000 or elan,ekt2xxx. What is the earliest product supported by
this driver?

Thanks.

-- 
Dmitry
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help