On Thu, 31 Jul 2014, Jassi Brar wrote:
On 23 July 2014 20:56, Lee Jones [off-list ref] wrote:
quoted
On Wed, 23 Jul 2014, Jassi Brar wrote:
quoted
quoted
quoted
quoted
+ if (chan->txdone_method == (TXDONE_BY_POLL | TXDONE_BY_ACK))
+ chan->txdone_method = TXDONE_BY_POLL;
Unless you're leaving it there for clarity, you can drop the
"TXDONE_BY_POLL |" from if().
We need to check for both.
What I'm trying to get at is; if it's already TXDONE_BY_POLL, there is no
need to set it to TXDONE_BY_POLL.
In mbox_request_channel() we added the ACK flag, if POLL was set and
now we need to revert that in mbox_free_channel().
Okay, I see what you're doing. Thanks for the clarification.
--
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at http://vger.kernel.org/majordomo-info.html