Re: [PATCH 2/4] net: rfkill: gpio: remove gpio names
From: Linus Walleij <hidden>
Date: 2014-03-07 02:51:30
Also in:
linux-wireless, lkml, netdev
From: Linus Walleij <hidden>
Date: 2014-03-07 02:51:30
Also in:
linux-wireless, lkml, netdev
On Wed, Feb 26, 2014 at 1:35 AM, Stephen Warren [off-list ref] wrote:
On 02/25/2014 02:13 AM, Linus Walleij wrote:
quoted
So it is basically there to satisfy the habit in some device tree bindings to name gpio arrays instead of just passing gpios = <...>; (The latter should be encouraged going forward.)Do you really want to switch from named GPIO lookups to index-based GPIO lookups?
I don't know what I want. I only know that ACPI and DT people are starting to step on each others feet.
Index-based lookups make it much harder to extend the DT binding in a backwards-compatible fashion, especially in the face of optional GPIOs (of which all of CD, WP, power are).
You're probably right. At the same time it makes the world complex for the ambition to use the same interface for DT and ACPI alike. Yours, Linus Walleij -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org More majordomo info at http://vger.kernel.org/majordomo-info.html