Hi Sebastian,
On Thursday 23 January 2014 01:11:29 Sebastian Reichel wrote:
On Wed, Jan 22, 2014 at 11:57:45PM +0100, Laurent Pinchart wrote:
quoted
[...]
quoted
camera-switch {
/*
* TODO:
* - check if the switching code is generic enough to use a
* more generic name like "gpio-camera-switch".
I think you can use a more generic name. You could probably get some
inspiration from the i2c-mux-gpio DT bindings.
My main concern is, that the gpio used for switching is also connected to
the reset pin of one of the cameras. Maybe that fact can just be neglected,
though?
I'm not the only one to wish we could change that, but alas! we'll have to
live with that stupid hardware design decision :-)
What we want to ensure here is that the two sensors won't be accessed at the
same time, as that would lead to errors. This was previously handled by
callback function to board code, but board code is now going away. The
challenge is to find a way to express the constraints in DT. I'm not sure
whether that's doable in a generic way, and this might be one of the rare
cases where board code is still needed.
Sakari, have you given this a thought ?
--
Regards,
Laurent Pinchart