On 02/18/2013 04:30 AM, Wei Ni wrote:
Split set&show temp codes as common functions, so we can use it directly when
implement linux thermal framework.
quoted hunk ↗ jump to hunk
diff --git a/drivers/hwmon/lm90.c b/drivers/hwmon/lm90.c
-static ssize_t show_temp8(struct device *dev, struct device_attribute *devattr,
- char *buf)
+static void _show_temp8(struct device *dev, int index, int *temp)
This function now seems to be "get" not "show". If you rename it to e.g.
"get_temp8", then you won't need to use an _ in the function name. If
that name causes conflicts with later patches, perhaps "read_temp8".
-static ssize_t set_temp8(struct device *dev, struct device_attribute *devattr,
- const char *buf, size_t count)
+static void _set_temp8(struct device *dev, int index, long val)
Similarly, perhaps "write_temp8"?
Similar comments for the rest of the patch.