RE: [PATCH v4 4/5] dt/s3c64xx/spi: Use of_get_child_by_name to get a named child
From: Kukjin Kim <hidden>
Date: 2012-10-17 07:13:46
Rob Herring wrote:
On 09/25/2012 06:06 AM, Mark Brown wrote:quoted
On Mon, Sep 24, 2012 at 07:51:57AM -0500, Rob Herring wrote:quoted
On 09/22/2012 11:07 AM, Mark Brown wrote:quoted
On Tue, Sep 18, 2012 at 08:10:49AM +0100, Srinivas KANDAGATLA wrote:quoted
quoted
quoted
As follow-up to "dt: introduce of_get_child_by_name to get child nodebyquoted
quoted
quoted
quoted
name." patch, This patch removes some of the code duplication in the driver by replacing it with of_get_child_by_name instead.quoted
quoted
Applied, thanks. Please do use subject lines consistent with thethingquoted
quoted
quoted
you're submitting against.quoted
This dependency here is not yet applied. I was waiting for some acksforquoted
quoted
some other conversions in the series. I can take it or ack the dependency. Probably makes more sense for me to take it as there are other non-spi patches.Ugh, this isn't in mainline... looking at the original posting I see this wasn't sent as a threaded patch series, it was sent as a bunch of separate patches, so this got detached from the rest of the series. I discarded the patch.I've applied this one and it's dependency.
Just note, happens following error with non-DT such as s3c6400_defconfig... LD drivers/mmc/built-in.o drivers/spi/spi-s3c64xx.c: In function 's3c64xx_get_slave_ctrldata': drivers/spi/spi-s3c64xx.c:838: error: implicit declaration of function 'of_get_child_by_name' drivers/spi/spi-s3c64xx.c:838: warning: assignment makes pointer from integer without a cast make[3]: *** [drivers/spi/spi-s3c64xx.o] Error 1 make[2]: *** [drivers/spi] Error 2 I'm not sure anyone is fixing it now? Thanks. Best regards, Kgene. -- Kukjin Kim [off-list ref], Senior Engineer, SW Solution Development Team, Samsung Electronics Co., Ltd.