Re: [PATCH 3.6.0-rc5] dt: introduce of_get_child to get child node by name.
From: Srinivas KANDAGATLA <hidden>
Date: 2012-09-13 15:51:08
On 13/09/12 16:43, Rob Herring wrote:
On 09/13/2012 10:25 AM, Srinivas KANDAGATLA wrote:quoted
On 13/09/12 16:14, Stephen Warren wrote:quoted
On 09/13/2012 05:10 AM, Srinivas KANDAGATLA wrote:quoted
From: Srinivas Kandagatla <redacted> This patch introduces of_get_child function to get a child node by its name in a given parent node. Without this patch each driver code has to iterate the parent and do a string compare, However having of_get_child libary function would avoid code duplication, errors and is more convenient. Signed-off-by: Srinivas Kandagatla <redacted>You forgot to Cc the drivers/of maintainers, Grant and Rob. I have here.Oops...quoted
I can certainly see a use for this in many places; the "runtime interpreted power sequences" patch, and the regulator DT parsing code at least both could benefit from this.I would think the power sequences code would always iterate over the nodes.quoted
There are at-least 7-8 places in the current kernel which could use this function directly.Care to point them out and preferably fix them then. That would be more convincing that this is needed.
I did plan on sending all the 7 patches with this one, But I wanted to know overall opinion on introduction of this new function. Here are the instances of the drivers... which can benefit from this function.. drivers/tty/hvc/hvc_opal.c drivers/spi/spi-s3c64xx.c drivers/net/ethernet/freescale/fsl_pq_mdio.c arch/powerpc/sysdev/qe_lib/qe.c arch/powerpc/platforms/powernv/opal.c arch/powerpc/kernel/prom.c
Rob