Re: [PATCH 3.6.0-rc5] dt: introduce of_get_child to get child node by name.
From: Rob Herring <hidden>
Date: 2012-09-13 15:43:22
On 09/13/2012 10:25 AM, Srinivas KANDAGATLA wrote:
On 13/09/12 16:14, Stephen Warren wrote:quoted
On 09/13/2012 05:10 AM, Srinivas KANDAGATLA wrote:quoted
From: Srinivas Kandagatla <redacted> This patch introduces of_get_child function to get a child node by its name in a given parent node. Without this patch each driver code has to iterate the parent and do a string compare, However having of_get_child libary function would avoid code duplication, errors and is more convenient. Signed-off-by: Srinivas Kandagatla <redacted>You forgot to Cc the drivers/of maintainers, Grant and Rob. I have here.Oops...quoted
I can certainly see a use for this in many places; the "runtime interpreted power sequences" patch, and the regulator DT parsing code at least both could benefit from this.
I would think the power sequences code would always iterate over the nodes.
There are at-least 7-8 places in the current kernel which could use this function directly.
Care to point them out and preferably fix them then. That would be more convincing that this is needed. Rob