On 09/13/2012 05:10 AM, Srinivas KANDAGATLA wrote:
From: Srinivas Kandagatla <redacted>
This patch introduces of_get_child function to get a child node by its
name in a given parent node.
Without this patch each driver code has to iterate the parent and do
a string compare, However having of_get_child libary function would
avoid code duplication, errors and is more convenient.
Signed-off-by: Srinivas Kandagatla <redacted>
You forgot to Cc the drivers/of maintainers, Grant and Rob. I have here.
I can certainly see a use for this in many places; the "runtime
interpreted power sequences" patch, and the regulator DT parsing code at
least both could benefit from this.