Re: [PATCH v6] ARM: mtd: nand: davinci: add OF support for davinci nand controller
From: Heiko Schocher <hidden>
Date: 2012-08-07 14:34:40
Also in:
linux-arm-kernel
Hello, On 30.07.2012 09:22, Heiko Schocher wrote:
add OF support for the davinci nand controller.
Signed-off-by: Heiko Schocher<redacted>
Cc: davinci-linux-open-source-VycZQUHpC/PFrsHnngEfi1aTQe2KTcn/@public.gmane.org
Cc: linux-arm-kernel-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org
Cc: devicetree-discuss-uLR06cmDAlY/bJ5BZ2RsiQ@public.gmane.org
Cc: linux-mtd-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org
Cc: David Woodhouse<redacted>
Cc: Grant Likely<grant.likely-s3s/WqlpOiPyB63q8FvJNQ@public.gmane.org>
Cc: Sekhar Nori<redacted>
Cc: Wolfgang Denk<redacted>
Cc: Scott Wood<redacted>
---
- changes for v2:
- add comments from Scott Wood:
- add "ti,davinci-" prefix
- Dashes are preferred to underscores
- rename "nandflash" to "nand"
- introduce new "ti,davinci" specific properties for setting
up ecc_mode, ecc_bits, options and bbt options, instead
using linux defines
- readme fixes
- no changes for v3
- changes for v4
remove "pinmux-handle" property as discussed here:
http://www.spinics.net/lists/arm-kernel/msg175701.html
with Nori Sekhar
- no changes for v5
- changes for v6:
add comments from Sekhar Nori:
- remove unnecessary includes
- use devm_kzalloc instead of kzalloc
- remove AEMIF timing specific bindings, as
this has to be done later.
.../devicetree/bindings/arm/davinci/nand.txt | 51 ++++++++++++++
drivers/mtd/nand/davinci_nand.c | 72 +++++++++++++++++++-
2 files changed, 122 insertions(+), 1 deletions(-)
create mode 100644 Documentation/devicetree/bindings/arm/davinci/nand.txtping ... any comments? bye, Heiko -- DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany