On Fri, Jan 27, 2012 at 09:29:50AM -0800, Stephen Warren wrote:
Simon Glass wrote at Thursday, January 26, 2012 10:42 AM:
...
quoted
1. It doesn't seem to make full use of the device tree format. For example,
<TEGRA_PMX_PG_DTD TEGRA_PMX_CONF_DRIVE_STRENGTH 5>
would be better as something like
drive-strength = <5>;
if we could arrange it. It also reduces the need for these
TEGRA_PMX_CONF_DRIVE_STRENGTH defines.
Yes I can see the argument this is more readable.
However, it:
* Requires a lot of string handling when parsing the device tree, since
you have to search for lots of individual properties by name.
* Bloats the device tree quite a bit due to representing each parameter
as a separate property, with a longish name, rather than a single u32
cell in the config property I proposed.
It bloats device tree more due to the proposal needs to represent every
single muxable entity (pin for imx case) as a node to accommodate the
properties like 'drive-strength' here.
--
Regards,
Shawn