On Tue, 8 Mar 2011 21:13:00 +0000
Daniel Drake [off-list ref] wrote:
On 4 March 2011 18:01, Andres Salomon [off-list ref] wrote:
quoted
quoted
+static int __init declare_of_platform_devices(void)
+{
+ return of_platform_bus_probe(NULL, of_ids, NULL);
+}
+device_initcall(declare_of_platform_devices);
How about 'olpc_create_platform_devices' or some such name? That's
what's really happening here, right?
The reason I called it declare_of_platform_devices is because thats
what all the other platforms do (do a git grep). do you still think it
should be renamed?
Yes, unless there's some reason why it should be named "declare". I'm
assuming the names used in ppc platform device code are like that for
historical reasons?
_______________________________________________
devicetree-discuss mailing list
devicetree-discuss@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/devicetree-discuss