On Thu, Jun 10, 2010 at 12:40 AM, Benjamin Herrenschmidt
[off-list ref] wrote:
On Fri, 2010-06-04 at 15:21 -0600, Grant Likely wrote:
quoted
Merge common implementation of of_irq_map_one(). Rename it to
__of_irq_map_one() so that arch code can either use the stock
implementation, or override it to handle platform quirks.
Similar comment to before, I think the breakup of functions causes more
complication and bloat than just keeping the quirks in the generic code.
Okay. I had been trying to avoid #ifdefs in the common code, but
you're probably right. I'll rework.
g.