Thread (62 messages) 62 messages, 10 authors, 2017-07-05

Re: [PATCH v4 04/13] security/keys: ensure RNG is seeded before use

From: "Jason A. Donenfeld" <Jason@zx2c4.com>
Date: 2017-06-08 00:50:15
Also in: lkml

On Thu, Jun 8, 2017 at 2:31 AM, Theodore Ts'o [off-list ref] wrote:
I'm guessing you changed key_alloc_serial() to return an int back when
you were thinking that you might use get_random_bytes_wait(), which
could return -ERESTARTSYS.

Now that you're not doing this, but using get_random_u32() instead,
there's no point to change the function signature of
key_alloc_serial() and add an error check in key_alloc() that will
never fail, right?  That's just adding a dead code path.  Which the
compiler can probably optimize away, but why make the code slightly
harder to read than necessasry?
Good catch, and thanks for reading these so thoroughly that you caught
the churn artifacts. Do you want me to clean this up and resubmit, or
are you planning on adjusting it in the dev branch?
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help