On Tuesday 12 May 2015 17:54:31 Thomas Petazzoni wrote:
Dear Arnd Bergmann,
On Tue, 12 May 2015 17:49:08 +0200, Arnd Bergmann wrote:
quoted
Using
if (IS_ENABLED(__BIG_ENDIAN))
here would make it more readable by avoiding the #if. Alternatively,
you could leave the XOR_DESCRIPTOR_SWAP flag disabled and just swap
the descriptors manually like a lot of other drivers do. You have
to swap the mmio accesses anywya.
Agreed on IS_ENABLED(). However, I don't understand the comment about
the need to swap mmio accesses? We're using readl_relaxed() /
writel_relaxed(), and they do the swapping already. Am I missing
something?
Sorry for being unclear. This was exactly my point: readl_relaxed()
has to do swaps internally, and you can also do swaps when accessing
the descriptor in memory.
Arnd