Thread (1 message) 1 message, 1 author, 2014-07-26

Re: General flags to turn things off (getrandom, pid lookup, etc)

From: Eric W. Biederman <hidden>
Date: 2014-07-26 19:52:43
Also in: linux-api, lkml

Andy Lutomirski [off-list ref] writes:
On Fri, Jul 25, 2014 at 2:35 PM, One Thousand Gnomes
[off-list ref] wrote:
quoted
On Fri, 25 Jul 2014 11:30:48 -0700
Andy Lutomirski [off-list ref] wrote:
quoted
[new thread because this sort of combines two threads]

There is recent interest in having a way to turn generally-available
kernel features off.  Maybe we should add a good one so we can stop
bikeshedding and avoid proliferating dumb interfaces.
We sort of have one. It's called capable(). Just needs extending to cover
anything else you care about, and probably all the numeric constants
replacing with textual names.
The big difference is capable only subdivides roots powers (aka things
most applications should not have).  When we start talking about things
that things that are safe for most applications capable is probably not
the right tool for the job.

A much closer match is the personality system call.  Look at setarch
to see how it is used.  My biggest concern with personality is there
are only 32bits to play with.  Still I expect what you want may be a
sandbox personality, that disables everything that could possibly be
a problem (including access to the personality syscall).

Eric
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help