On Fri, 2023-12-22 at 14:19 +0300, kirill.shutemov@linux.intel.com wrote:
On Tue, Dec 05, 2023 at 11:36:55PM +0000, Huang, Kai wrote:
quoted
quoted
+
+static void acpi_mp_stop_other_cpus(int wait)
+{
+ smp_shutdown_nonboot_cpus(smp_processor_id());
+}
Is this and ...
+ smp_ops.stop_other_cpus = acpi_mp_stop_other_cpus;
... this below still needed?
I think the current native_stop_other_cpus() should just work given you have set
up ...
+ smp_ops.crash_play_dead = crash_acpi_mp_play_dead;
... for TDX guest?
To make it work stop_this_cpu() would need to be modified to use
smp_ops.crash_play_dead() instead of native_halt(). But name of the
callback doesn't match the function, so I renamed it to
smp_ops.stop_this_cpu().
Seems reasonable to me. Thanks.